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INTRODUCTION
This training guide provides instructions on how to use the InDesign Plug-In for the GN4 
Publishing system.  It is assumed that the user has prior knowledge of the i4 system and 
features that are part of i4 will not be specifically covered in this guide.

When installed, the GN4 Plug-In adds a menu panel and palette to Adobe InDesign, InCopy 
and Photoshop for versions CC2021 and CC2022. No other versions of Adobe software are 
catered for currently. To see the Plug-Ins version number, on a PC go to Help>About Plug-
Ins>GN4 (or InDesign>About Plug-Ins>GN4 on a Mac).

INSTALLING THE PLUG-INS

There are two parts to the installation of the plug-in

1.	 The i4 Extension (I4.ZXP)
2.	 The Adobe InDesign Plug-in (com.Miles33.GN4.zxp for PC, GN4Plugins2021.dmg for Mac 

– CC2022 versions are also available)

I4 Installation - Mac

On a Mac, you will need to install the i4 Extension first and this can be done easily using 
a third party application called ZXP Installer.  ZXP Installer can be obtained from https://
zxpinstaller.com.  Once you have ZXP Installer installed on your local machine, with Adobe 
InDesign open in the background, drag and drop the i4 Extension onto the ZXP Installer 
window.  This will start the installation process for you.  Once the installation has completed 
you should close InDesign.

Adobe InDesign Plug-in – Mac

To install the InDesign Plug-in on a Mac, ensure InDesign is not running then open the 
GN4Plugins2021.dmg and then copy all of the files to the following location:

/Applications/Adobe InDesign 2021/Plug-ins

Installation on a PC

Both the i4 Extension and the Adobe InDesign plug-in can be installed at the same time on a 
PC. To install these items, ensure all Adobe applications are shut down, open the ZXP Installer 
(see above for obtaining this application) and then drag and drop the com.Miles33.GN4.zxp 
file onto the ZXP Installer window.

Once everything is installed, you can open InDesign and you should have available a GN4 
menu item under the Plug-ins Menu and also the GN4 extension available under the Window/
Extensions Menu.

https://zxpinstaller.com
https://zxpinstaller.com
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LOGGING IN FROM WITHIN INDESIGN

To login to GN4, the palette needs to be opened from the Windows>Extensions>GN4 menu. 
You will need to provide the URL of the server you are connecting to along with your user 
name and password. You should also provide a general name (of your choice) for this 
connection.  If you need to connect to multiple sites, this will allow you to switch between the 
sites without having to re-enter the URL each time.

If the login times out due to no or slow connectivity then an appropriate error dialog will be 
displayed. If your username and/or password are not valid then the error dialog below will be 
displayed:

If this occurs then the user can check the login details, select OK and try again. If the login 
attempt(s) continue to time out you will need to consult with your System Manager.
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GENERAL NAVIGATION
THE GN4 PALETTE

Once you have logged in, you will see the GN4 palette (as per the example pictured below). 
The GN4 palette will behave in the same way as any other palette of the Adobe application 
you are using it in.  It can therefore be resized, collapsed, grouped with other palettes as a 
tab etc.  Because there is a lot of information that requires a large amount of screen size, it is 
recommended where possible that a second screen is used from which the GN4 palette can 
be used.

The buttons highlighted in the image above in the top left corner include the burger menu 
button which toggles the side bar menu on and off, the GN4 button which takes you to a cut 
down version of the GN4 interface and the Pages button which brings you back to whatever 
menu item you were previously on within the palette. The burger menu on the right hand 
corner allows you to log off from the system.

The lighter blue items on the sidebar e.g Content can be expanded by clicking on them.

The items that you see in the above screen shot will depend upon the configuration of the 
system.  These items are the search menu items and allow you to access the various objects 
based on a filtered search.
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SEARCHING

When you click on one of the search menu items, depending on the system configuration, you 
will typically be presented with a search page like this:-

Clicking on the Toggle Search button will open a search form that will allow you to filter down 
results.  The various search forms will be different for different objects but these are some 
typical examples of search contexts that are likely to be used:-

Articles

For articles it is possible to search on text contents, name, the folder, the date it was modified 
or created, the category it is in and whether it is linked or not.  The drop down menus give you 
greater filtering abilities, e.g.:-
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Editorial Images

Editorial images can be searched according to what folder they reside in, their name, the 
date they were modified or the date they were created.

Archive Images

Archive Images again will have a different set of search criteria to use. All of the above 
searches are configurable by the systems manager and therefore the screen shots illustrated 
may not entirely reflect what individual users will see.
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SEARCH RESULTS

Once you have selected your search criteria and have clicked the refresh icon your 
results will be listed below the search form and it is possible to alter the way the results are 
displayed.  For example, when you have searched on Articles, you are able to alter the sort 
order in which items are displayed by changing between the modified date, the name, the 
folder name and the workstate from either the drop down menu shown below or by clicking on 
the various headings in the table:-

When you click on the settings icon you can alter the number of results that are displayed 
on the page (0 selects the default value of 25 per page otherwise you can set it to anything 
from 1 to 50).  You can also specify the number of layout columns displayed between 3 and 
12:-

When you have searched for any type of image or page, you can also toggle between list 
view or icon view:-
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SAVING SEARCHES

It is possible to save any of your searches by clicking on the save button. You will be 
required to give the saved search a name:-

Once you have any searches saved, a new item will appear in the sidebar menu listing all 
of your saved searches. You can click on the burger menu to change the order the saved 
searches appear in the list (using the up and down arrows highlighted below) and delete them 
if necessary from the ‘Manage Saved Searches’ window:-

ADDING ITEMS TO CLIPBOARD

You can add anything from a search result to the clipboard by selecting the item and then 
clicking on the paper-clip icon (‘+’ will add the selected item to your clipboard and ‘–’ will 
remove the selected item from your clipboard):-

You are then able to view and access all items on your clipboard from the sidebar menu:-
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EXTERNAL DOCUMENTS (EXTDOCS)
InDesign documents created within the GN4 system are known as ExtDocs.  ExtDocs can be 
generated from existing Fred documents and/or InDesign Template Editions.  Either a single 
page document or a whole Edition of page documents can be created.  Enablement of this 
feature is controlled by back end I4 configuration and can be set for different users or for 
different groups.

CREATING THE INDESIGN TEMPLATE FOR USE WITH THE INDESIGN 
PLUGIN

The InDesign Template only needs to match the Master Pages of the equivalent Fred 
Template. Therefore for a basic template only a Left, Right, Frontpage and Double are 
required that matches the master Fred Masters.

To create this template we need to create an InDesign document that contains the relevant 
master pages configured with any required layouts/grid, page furniture and folios.

The screen shot above shows an example of such a document where all the required master 
pages have been set up (although it could be that the Left and Right pages can use the 
‘Double’ master and therefore you don’t necessarily need 4 separate masters configured 
within InDesign).

We now need four separate InDesign Documents to upload as templates for Left, Right, 
Double and Frontpage (ensuring that each page is using the relevant master):-
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To upload these templates for use with the InDesign Plugin open one of the above documents 
in InDesign and then from the GN4 plugin click on ‘Import Current Template’:-

At the ‘Upload – Edition information’ screen, enter the name of the template so that it 
matches the relevant master page of the equivalent Fred Template – in our example below 
we enter ‘Left’. Then select the Edition you want to upload the template for, the section, zone 
and booklet.  Then click Next:-

Repeat the above step until all templates are uploaded.

Please note that it is important to remember to save the source InDesign Document prior 
to each upload. It is also a good idea to insure that the ‘Section Prefix’ and ‘Section Marker’ 
fields under ‘Numbering & Section Options...’ for the InDesign Master Page are blank.

See the following screen shot which shows what the ‘Numbering & Section Options...’ window 
should look like:-

When an extDoc created in this way is subsequently opened the Advertising Layer will always 
be updated to that of the corresponding Fred page.
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CREATING INDESIGN (EXTDOCS) FROM AN EDITION

To create a whole Edition of InDesign documents, search for the Edition you want to use then 
either from the Context menu or the Actions button select ‘Create InDesign’.

At the ‘Find Edition Template’ dialogue, you can select a template that you wish to use or you 
can leave templates unselected and click ‘Next’ – in which case all pages will be created the 
same size based on the Fred Pages Master page.  The system will now go and create the 
documents for you:-

If an InDesign document already exists in the Edition for that page folio, running this function 
will NOT recreate or overwrite the document again. If the document is required to be re-
created then the existing InDesign document must be deleted first.

If there are existing Template Edition documents (of extDoc format) for the Title you must 
choose which one you want to utilise. If there aren’t any Template Edition documents available 
for the Title then an extDoc is created using the Fred Pages Master page. Both Editorial and 
Advertising Layers are created from this document.

If the chosen Template Edition document contains a page name folio matching that of the 
Fred page folio (i.e. Page 6) then the Template Edition document (extDoc) is used to create 
the page documents dimensions and Editorial Layer but the Advertising Layer is created from 
the Fred page.

If the chosen Template Edition document doesn’t contain a page name matching that of the 
Fred page (i.e. Page 6) but does have a Master page name matching that of the Fred pages 
Master page name (i.e. LEFT), then the two matching Master page(s) are used to create the 
Editorial Layer (from the Template Edition Master extDoc) and Advertising Layer (from the 
Fred Page Master page) respectively.
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If there are no matching Master page names between the Template Edition document 
and the Fred page then the Fred pages Master page is used to create the Advertising and 
Editorial Layers.

If any Fred document used to create an extDoc page has Editorial or standing material on it, 
this content is not transferred onto the created InDesign document. Only the Advertising Layer 
content can be inserted from a Fred page when an InDesign document is created.

The logic used for the creation function is below: 

CREATING INDESIGN (EXTDOC) FROM A PAGE

To create a single InDesign document from an existing FRED page, search for the page you 
want to create then either select the page and click the Actions button or using the drop 
down context menu click ‘Create InDesign’:-
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At the ‘Find Edition Template’ dialogue, you can select a template that you wish to use or you 
can leave templates unselected and click ‘Next’ – in which case all pages will be created the 
same size.  The system will now go and create the documents for you:-

When you are creating just a single page, the document will open up in InDesign for you.

OPENING AN INDESIGN DOCUMENT

InDesign documents can be opened via the ExtDocs menu or via the Editions menu.

To open an an InDesign document via the ExtDocs menu, click on the ExtDocs item from the 
side bar then click on the ‘Toggle Search’ button to expand the search form:-



  17											           © Naviga Inc. - 2022

GN4 ADOBE PLUG-IN TRAINING GUIDE
PUBLISHING SYSTEM

GN
Specify at least one search criteria item to filter the results by and then click on the refresh 
button:-

From the results of your search, you can select and open one or more documents either by 
clicking on the rows, selecting Actions and then open from the menu, or using the context drop 
down menu and choosing open:-

It is also possible to open the document from the ‘Properties’ page.

To open an InDesign document from the Editions menu item, click on the Editions item from 
the side bar then click on the ‘Toggle Search’ button.  Enter at least one search criteria 
item in the search form and then click the ‘Refresh’ button.  From the resulting list of your 
search, select the Edition containing your InDesign document and either from the Actions 
button or the context drop down menu select ‘Indesign Docs’:-

This will now show you a thumbnail of your pages within the selected edition and you can 
open an individual InDesign document by selecting open from the dropdown menu, by 
selecting the Actions button and clicking open or by opening the properties of a document 
and clicking open:-
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If the extDoc is locked it will ask if you want to open the page in Article Mode:-

A progress bar will run whilst the document is opening. When in ‘Article Mode’, the user will 
only be able to make changes to the text but not the layout of the page.

ADVERTISING LAYER

When an extDoc is opened via the Plug-In, the latest saved Advertising Layer Layout is 
always uploaded with the document, even if this overlays page document content that was 
already present before the advertising layer layout change.

The Advertising Layer will be locked.
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CHECKING OUT AN INDESIGN DOCUMENT TO USE OFFLINE

To use an InDesign document offline, search for the extDoc using the methods above and 
then from the context menu select the offline option:

This will check out the document and open the checked out version. These files are 
downloaded to the user documents folder in a folder typically called ‘Miles_33_GN4’.

ADD CURRENT INDESIGN DOCUMENT INTO GN4

To add an InDesign document into GN4 from InDesign, with the document open in InDesign 
click the ‘Import Current Document’ button from the GN4 plugin window:-

At the resulting ‘Upload – Edition information’ screen, use the drop down lists to select the 
edition, section, zone and booklet of where you want to upload the document to:
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Only InDesign documents that have been saved can be uploaded; attempting to upload a 
new unsaved document will generate an appropriate error message.

When the document has been added it will close the current document and open the one that 
was added to GN4. The name of the extDoc defaults to the page number. The ability to add 
pages is disabled by default.

If the document being uploaded to the system contains text boxes with content in, they will 
by default be set to a box type of Disable Import so that once the document has been added 
it can be opened and closed without the user being forced mark the types of text boxes 
throughout the document (and then having to import content into the GN4 system if the box 
type is not set to Disable Import). This enables a template document containing standing 
matter text boxes to be uploaded to the GN4 system and used without excessive initial 
manual user intervention. Boxes containing content marked with a type other than Disable 
Import must always have the content imported into the GN4 system (see Importing items on a 
page document into GN4).

COPYING EXTDOCS

Using the copyExtDoc menu item from the drop down list, the user can select an InDesign 
page or pages (extDoc) and copy them to another page document. The Copy Document 
dialog will be presented for the user to enter the required Edition, Section, Zone, Booklet, Page 
number (only shown if a single item is selected) and Prefix of the new document that will be 
generated from the original. The Prefix allows articles to be copied with that given prefix.  If 
this is left empty, the articles are not copied. If an article of the name exists it is over written. 
Also, if there are any jumps on the page only the part of the jump story on the current page is 
copied.

MANUALLY ADJUSTING PAGE NUMBERS AND NUMBER OF PAGES IN 
THE DOCUMENT

If the folio is manually altered using the InDesign function (Layout>Numbering & Section 
options…) or the number of pages in the document is added to via the InDesign Pages 
Palette, the manual alterations are honoured and saved providing the user has the required 
permissions. If the user does not have the right permissions then an error will result on saving 
the document:

In the example above, page 2 had its folio altered by a user without the correct permissions 
and received the above error when attempting to save the document.
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ASSIGNED TO CURRENT DOCUMENT

This shows images (.img files) and articles in GN4 that are assigned to the currently open 
extDoc. It will show items assigned to the extDoc, zone, edition and section.

PLACING ARTICLES OR STORIES ONTO PAGE (EXTDOC) DOCUMENTS

There are two ways to place Articles and Stories into the InDesign document, 1) Place in 
Selected Boxes and 2) Place.

1.	 	Place in Selected Boxes
In order to place an article into the selected boxes within the InDesign document, with the 
extDoc open and the tagged frames on the document - you need to navigate to the article 
you want to place.  The ‘Place in Selected Boxes’ menu item can be selected from either:-

The Drop down menu

The Action button

The Preview and 
Properties screen

Any known types (e.g. Headline, Body, Photo Catption) will be placed in the appropriate 
selected boxes. If there is a choice of box for the text types or more than one type to be 
placed into a box you will be given a choice to select the item to put into the box. The 
feature will cycle through the boxes which are selected and you have the option to skip or 
place an item. It will only ask once per box. If it is left with a single match then the item is 
automatically placed.
2.	 	Place

To use the place functionality, with the extDoc open in InDesign, navigate to the article you 
want to place. By selecting the ‘Place’ menu item (which is found once again from the drop 
down menu, the Action button or the Preview and Properties screen) each section of the 
article will be sent to the place gun and you can just click on the document and place the 
text, or draw a frame in the position you want.

The reference objects .img link to the photo caption. The img is only added when the photo 
caption needs to be placed. Articles can only be placed in one extDoc, if the article is already 
linked to an extDoc and you try to place it on another page, the extDoc it is placed on will 
open instead.
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REPLACING PAGE CONTENT ON PAGE DOCUMENTS

To replace content already on an extDoc (InDesign document) select the box with the content 
in on the page, select the content you want to replace it with from an article and press the 
place in selected boxes button. A dialog box will appear:

If you select Cancel or No, the operation will be aborted and the existing content in the box on 
the page document will remain. If you click on Yes, the page content will be removed from the 
page box and the selected content will replace it.

If the content you are replacing is the first part of a jump story, the content will then need to 
be reflowed so that any subsequent jump parts already on a page will be replaced too.

AUTOMATED CREATION OF ARTICLES FROM STORIES

If a Story is selected and inserted onto a Page Document (extDoc) it will automatically be 
copied to an Article and placed in the default folder that has been configured.

A Story cannot itself be added to a Page Document so on request to insert it into one the 
Story will be automatically copied and an Article generated and it is the Article that is 
inserted into the Page Document.

The Article that is created will be named using the original Story Name plus a unique GUID 
that is generated on-the-fly so that the overall Article name cannot be a duplicate of an 
existing Article name. If a used Story is inserted into a Page Document a second time the 
GUID will be different and therefore the overall Article Name will be unique.

AUTOMATED CREATION OF EDITORIAL IMAGES FROM WIRE IMAGES

If a Wire image is selected and inserted onto a Page Document (extDoc) it will automatically 
be copied to an editorial image and placed in the default folder that has been configured 
using the same settings as the automated creation of articles from stories.
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ITEMS IN CURRENT DOCUMENT

The Items Tab lists the .imgs and article types that are on/in the currently active open extDoc 
(InDesign) document or documents.

PENDING JUMPS

The PendingJumps search item lists the jumped and pending jump article components 
available in the open extDoc(s).

The Sequence Number column indicates the order of the jump parts. The original story 
content that the create jump was performed on is sequence number 1 and the remaining 
content not shown on the original extDoc at that point is sequence number 2. Both parts of 
the jump are listed. Note: A jump story can have more than 2 parts to it and so sequence 
numbers bigger than 2 are possible.
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To set up the jump text, within the InDesign document, right click on the overset text box and 
then navigate to the GN4 menu – select Jump and then either Create or Create Known Page:-

PLACING A PENDING JUMP INTO A DOCUMENT

To place a pending jump, with the ExtDoc open, select the correct sequence number item in 
the list (sequence2 or above). Click on the drop down menu and select either Place or Place in 
Selected boxes. Placing jump text operates in the same way as placing general text content 
(see Placing Articles or Stories onto Page (extDoc) Documents in this reference guide).

Text can only be jumped onto extDocs in the same Edition, Section, Zone and Booklet but 
cannot be jumped onto the same extDoc (so can’t, for example, be jumped onto another page 
in a multiple page extDoc or onto both pages of a double-page spread if it is produced as a 
single document). A Known Page pending jump has its intended destination page folio listed 
in the Jumps tab under the Known Pending Jump Page Number column but this is only for 
guidance purposes; no restriction is placed on the user overriding the intended pending jump 
destination by placing it on another page but the Known Pending Jump Page Number column 
row does signify this by displaying a red background colour.
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INDESIGN PLUG-IN MENU OPTIONS
EDITING TEXT

To edit text in InDesign that has been placed from GN4 it must be checked out. Attempting 
to edit in the box will ask if you want to check out for editing or you can use the menu 
Edit>InCopy>Check Out or context menu InCopy>Check Out) to check out the item.

When you have finished editing the item needs to be checked in. This is done with a menu 
(Edit>InCopy>Check In or context menu InCopy>Check In) or you are asked when you close the 
document. To save text when the item is checked out and not check it back in use the menu 
(Edit>InCopy>Save Content or context menu InCopy>Save Content). Please note when you 
logout (i.e. close InDesign) all items are automatically checked In.

If the text is linked to the extDoc more than once (content is copied and pasted) then the last 
edited text box content when saved will update (or require the links to be updated) all the 
other text boxes containing the same article.

EDITING PICTURES

To edit pictures you need to open them in Photoshop. Photoshop needs to be running and you 
must be logged in to GN4 in Photoshop. Select the pictures you want to edit from within the 
InDesign document and choose the menu Plug-Ins>GN4>Edit or context menu GN4>Edit. This 
will open the pictures in Photoshop. See Photoshop GN4 plug-in section later in this guide for 
more detailed information on editing pictures.

IMPORTING ITEMS ON A PAGE DOCUMENT INTO GN4

Importing items from the page into GN4 can take place via the menu (Plug-Ins>GN4>Create 
New Article /Img) or context menu (GN4>Create New Article /Img). A dialog is displayed which 
lets you enter the name (title) and folder for the imported content. It will automatically default 
to the last folder you used. It will import the items that are selected in the document.

To add to an existing article use the menu Plug-Ins>GN4>Add to Article or context menu 
GN4>Add to Article. This brings up a dialog that lists all the articles on the current page. 
Select the article you want to add the items to.

Images use the file name as the name of the img in GN4, and will ask if the img exists and 
give you the option to overwrite it.
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ASSIGNING TYPES TO INDESIGN BOXES

Boxes in InDesign need to be marked with the text type of an article. Select the box to be 
marked and choose a text type from Plug-Ins>GN4>Type or GN4 context menu. The type is 
shown on the box in a red label. When all boxes are marked, select all the boxes for an article 
and choose import from Plug-Ins>GN4>Create New Article /Img. You can only import one 
article at a time. You cannot overwrite an existing article. The available Types are defined in 
GN4’s configuration.

When the document is saved it will check to see if any items need to be imported into GN4. 
If there are items to import then the document save will not be allowed and an error dialog is 
shown.

To import a text part that has a reference (i.e. Photo caption) to another object the box needs 
to have a link to another box which is the reference object. There are two ways to achieve 
this:

	y Group the two boxes together using the standard InDesign group (CTRL+G) when the 
boxes are selected.

	y Select the two boxes and select Plug-Ins>GN4>Link.

The best way to link boxes is the former option as the group box can be used in library 
shapes.

To disable the import of boxes content use the menu Plug-Ins>GN4>Type>Disable Import 
or context menu GN4>Disable Import. This will not allow the contents to be imported into 
GN4 but will disallow the box from being checked for updates (therefore it can be used for 
standing matter).



  27											           © Naviga Inc. - 2022

GN4 ADOBE PLUG-IN TRAINING GUIDE
PUBLISHING SYSTEM

GN
SETTING THE DOCUMENT WORKSTATE

To set the workstate of the document from InDesign select the menu Plug-Ins>GN4>Workstate 
or context menu GN4 and choose the workstate. If the document needs to be saved it will be 
force saved.

CREATING PDFS OF PAGE DOCUMENTS

To create a PDF variant of the Document select Plug-Ins>GN4>Create PDF. A dialog is shown 
with a choice of variants (if more than one in the system). The variant name needs to map 
to the InDesign PDF export styles. The name can have ‘PDF_’ in front of it as this is removed 
when looking for the PDF export style.

There is a mapping of the Adobe PDF presets in InDesign to export the document as a PDF 
variant in GN4. The presets need to be added as Doc variant types in GN4. They can have 
‘PDF_’ put in front of the name as then it will display in the Create PDF dialog.

INDESIGN BOX TYPE LABELS

There are three types of labels that can be displayed in the InDesign Normal Screen Mode 
only (View>Screen Mode>Normal):

	y Red – show the type of box that needs to be imported into GN4. The Menu to toggle the 
label on/off is Plug-Ins>GN4>Labels>Type.

	y Blue – shows the type of content that it is linked to (body, head etc.). The Menu to toggle 
the label on/off is Plug-Ins>GN4>Labels>Linked.

	y Image Labels - generally shows the image name and it’s description but this is 
configurable and other meta data items can also be shown.  The Menu to toggle the  
label on/off is Plug-Ins>GN4>Labels>Images.
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INDESIGN FOLIO MARKERS

There are markings for page number, section, zone and edition number and they are updated 
when the page is opened. Below is the list of context menus to add to each marker:

	y Page: Insert Special Character>Markers>Current Page Number
	y Section: Insert Special Character>Markers>Section Marker
	y Zone: Insert Variable>Zone
	y Booklet: Insert Variable>Booklet (Booklet is only for GN4 2.4 and above)
	y Edition Number: Insert Variable>Edition Number

Below is the list of menus to add to each marker:

	y Page: Type>Insert Special Character>Markers>Current Page Number
	y Section: Type>Insert Special Character>Markers>Section Marker
	y Zone: Type>Text Variables>Insert Variable>Zone
	y Booklet: Type>Text Variables>Insert Variable>Booklet (Booklet is only for GN4 2.4 and 

above)
	y Edition Number: Type>Text Variables>Insert Variable>Edition Number

There are multi markers for edition date. All are found under Type>Text

Variables>Insert Variable or context menu Insert Variable.

	y Edition Date – Long date representation dependent on your system and system’s 
settings

	y Edition Date (Short) – Short date representation dependent on your system and
	y system’s settings
	y Edition Weekday – Full weekday name
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	y Edition Weekday (Short) – Abbreviated weekday name
	y Edition Month Name – Full month name
	y Edition Month Name (Short) – Abbreviated month name
	y Edition Day – Day of month as decimal number (1-31)
	y Edition Day (01) – Day of month as decimal number (01 – 31)
	y Edition Month – Month as decimal number (1 – 12)
	y Edition Month (01) – Month as decimal number (01 - 12)
	y Edition Year – Year with century, as decimal number
	y Edition Year (Short) – Year without century, as decimal number (00 – 99)
	y Edition Day of Year – Day of year as decimal number (1 - 366)
	y Edition Day of Year (001) – Day of year as decimal number (001 – 366)

AUTO CHECKOUT

This is on by default. Auto Checkout an item to be edited if it is selected with the text tool. 
When Auto Checkout is on it will unlock the items when the document is closed. To toggle this 
on/off use the menu Plug-Ins>GN4>Auto Checkout. If auto checkout is on and you are editing 
an item and select to check in the item it will re-check out the item.

DOCUMENT COMPLETE FUNCTION

This function will:

	y Check all items in
	y Save the page
	y Create print PDF and send it to the print queue (configurable)
	y Create PDF for archive and store it in a variant on the ExtDoc (configurable)
	y Set the workstate (configurable)
	y Close the document

REMOVE CONTENT FROM DOCUMENT

To remove content from boxes select the boxes the content is to be removed from and then 
select Plug-Ins>GN4>Remove Content or context menu GN4>Remove Content. This will remove 
all pictures and empty all text from the selected shape. Note that Remove Content will also 
remove content that is not in GN4 from the document. Remove Content performed on a 
jumped text box will remove both the text content and the jump continued on/from box and 
content. If all parts of a jump have been removed then the Jump story will be delisted from the 
Jumps Tab.

SPIKE CONTENT FROM DOCUMENT

This works the same as Remove Content from the document but it can only be used on text 
and images that are in GN4. It will run the remove content from the page, save the page then 
it will spike the items from GN4.

PREFLIGHT PROFILES

The InDesign Preflight option (Window>Output>Preflight) has a pre-configured GN4 Rule 
Category installed into the Basic Profile and by default all options are switched on.
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To remove the GN4 Rule Category (all the GN4 Prefight options) another Profile (other than 
Basic) will need to be created (within the Define Profiles dialog) and the tick removed from 
the GN4 Rule Category level. To remove an individual Preflight option, create another profile 
and remove the tick against the appropriate Preflight option row. Depending on the actual 
functionality, Preflight options can be invoked and run when a document is edited, updated, 
saved or closed.

NOT IN GN4

The Not In GN4 profile is invoked when a text box has content entered into it and the box 
is not known by the GN4 system. If the Preflight panel dialog box is open (by either double-
clicking on the Status Bar error section or opening from Window>Output>Preflight) the display 
will show the Not In GN4 list of Text Frames. Highlighting one of the Text Frames in the list will 
display the Problem text information in the Info area.

Double-clicking on the Text Frame in the list will force the offending Text Frame in the InDesign 
document to be selected and brought into view.

A Text Frame failing this Preflight option must either be added into GN4 or marked as 
Disabled for Import.

This profile is also run by the File>Save document function.

REFLOW CHECK

The GN4 Reflow profile is invoked when a jump text box requires a Plug-Ins>Jump>Reflow 
as the content or text frame has been adjusted. If the Preflight panel dialog box 
is open (by either double-clicking on the Status Bar error section or opening from 
Window>Output>Preflight) the display will show the GN4 Reflow list of Text Frames. 
Highlighting one of the Text Frames in the list will display the Problem text information in the 
Info area.
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UTILITIES

Utilities menu options (Plug-Ins>GN4>Utilities) are ‘Disable All Boxes Import’, ‘Disable All 
Graphic Boxes Import’, ‘Disable All Text Boxes Import’ and ‘Select First Import’.

DISABLING ALL BOXES FROM GN4 IMPORT

The menu option Plug-Ins>GN4>Utilities>Disable All Boxes Import will run the commands of 
‘Disable All Graphic Boxes Import’ and ‘Disable All Text Boxes Import’.

DISABLING GRAPHIC BOXES FROM GN4 IMPORT

The menu option Plug-Ins>GN4>Utilities>Disable All Graphic Boxes Import will scan all current 
Graphic boxes on the extDoc Page Document and mark all those not currently linked to GN4 
editorial images as being disabled for import into the GN4 system (option Plug-Ins>GN4>Type 
is ticked as Disable Import).

This feature enables the end user to easily disable for import all graphic boxes on the extDoc 
that are not GN4 editorial images but enable the extDoc document to be saved.

DISABLING TEXT BOXES FROM GN4 IMPORT

The menu option Plug-Ins>GN4>Utilities>Disable All Text Boxes Import will scan all current text 
boxes containing text on the extDoc Page Document and mark all those not currently linked to 
GN4 articles as being disabled for import into the GN4 system (option Plug-Ins>GN4>Type is 
ticked as Disable Import).

This feature enables the end user to easily disable for import all populated text boxes on the 
extDoc that are not GN4 articles but enable the extDoc document to be saved.

Double-clicking on the Text Frame in the list will force the offending Text Frame in the InDesign 
document to be selected and brought into view.

This profile is also run by the Plug-Ins>GN4>Document Complete function.
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SELECT FIRST IMPORT

Selecting menu item Plug-Ins>GN4>Utilities>Select First Import will scan all current boxes on 
the extDoc Page Document in the order drawn and select and bring into the window focus 
the first found box that is marked as a valid GN4 box type (options from Plug-Ins>GN4>Type 
other than Disable Import) that is not currently in the GN4 system.

This feature enables the end user to easily find unlinked items on extDocs and then import 
them into GN4 via the Plug-Ins>GN4 options of Add to Article or Create New Article/Img.

UPDATE ON OPEN

If the Update On Open menu option (Plug-Ins>GN4>Update On Open) is ticked (on) it will 
enable all the content Links within an extDoc being opened to be updated during the opening 
extDoc process and thus ensure all the content displayed is the latest known version. By 
default, the option is ticked (on).

If the option is not ticked (off) then on opening an extDoc the Links within it to the containing 
content will not be updated and some of the content may be out of date. A manual Links 
update can be performed by the operator when desired.

CHECK IN OFFLINE DOCUMENT

To check in a document that is offline, Open the offline document and then select the menu 
check in Document (Plug-Ins>GN4>Offline>Check In Document). This will save the changes of 
the document to the server and check in the document.

If there are any items that are not in GN4 then these need to be added before the document 
can be checked in.
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You will then be presented with the same log-on panel covered earlier in this guide (see 
‘Logging in from within InDesign’).  If you close Photoshop without using the menu logout and 
exit you will not be logged out. If you close Photoshop with documents open and unsaved 
these will not be saved into GN4.

The Photoshop panel, effectively works in the same way as the InDesign panel and the items 
that are available within the panel will depend on the configuration that has been set up and 
so some items and images in the guide may differ to what individual users see.

SEARCHING

Searches are conducted in the same way as within the InDesign panel - for example, to 
search for Editorial Images, click on the Editorial Images item on the side bar and then click 
on the magnifying glass icon to toggle on the search form.  Enter the search criteria 
required in the form and then click on the refresh icon to show your search results:

GN4 PLUG-IN - OTHER ADOBE 
APPLICATIONS
When you install the GN4 plug-in as described at the start of this guide, you will also be able 
to access the GN4 panel from within other Adobe applications including Photoshop, InCopy 
and Premiere.  The following section provides information on using the plug-in within those 
applications.

PHOTOSHOP GN4 PLUG-IN

In order to use the Photoshop GN4 plug-in, the version of Photoshop you use must match the 
version of InDesign you are using.

To open the extension, click Window>Extensions (legacy)>GN4.
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Use the drop down menu on an image to open it in Photoshop, view the properties, delete the 
image or move it to a different folder.

IMPORT EDITORIAL IMAGE

To upload an image from Photoshop, with the image open in Photoshop click on the Import 
Editorial Image link at the bottom of the panel.

In the resulting form, select the folder where the image should be stored and complete any 
other information as necessary, then click Next.

Click finish at the dialog window.  When the image has been added it will close the current 
document and open the one that was added to GN4.
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EDITING PHOTOS

To edit a photo that is placed on the page within InDesign, select the image and then right 
click to select the GN4 menu.  There are two options, Edit and Edit and Convert.  When you 
chose the Edit option, the image will open in Photoshop where you can edit it.  However, you 
will then save the image locally and will therefore need to reimport it for use in GN4.

When you chose the Edit and Convert option, the image will open in Photoshop but will be 
converted into .PSD format.  This will allow you to edit the image in whatever way is required 
and then you are able to save the image.  Within the InDesign document you can now update 
the link in order to display your edited image.  The image thumbnail within the GN4 panel will 
also reflect your change.

REVERTING THE CHANGES

If you have edited an image but then need to revert back to the original, this can be done by 
navigating to the image within the InDesign panel, selecting the dropdown menu and clicking 
Revert to original.  You will once again need to update the link within InDesign and then the 
original image will be reflected in the thumbnail as well as in the document.

INCOPY GN4 PLUG-IN

The InCopy GN4 plug-in provides a method of editing articles directly in InCopy without being 
able to change the layout of items placed on a page.

Once installed you will need to log on to the extension in the same way as the other Adobe 
applications (Window>Extensions>GN4 to open the panel and then log on with the correct 
URL, username and password).

As with the other GN4 panels, the items a user sees will depend upon their specific 
configuration.  This panel will work in the same way as the other GN4 panels but will have 
features that are relevant to InCopy.
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OPENING AN ARTICLE

To open an article within InCopy, use the search form from the InCopy GN4 plug-in to find the 
article you require and then use the drop down menu or the Actions button to select Open.

The selected content will be available to edit and the user will be able to select between 
either galley, story or layout mode.  If the article has been placed on a page, the layout 
mode will be a representation of the page, otherwise the layout mode will just show a 
‘dummy’ layout.  Within galley and story modes, a bar will display the name of the article, the 
component type (e.g. top strap, body etc.) and whether that component type is available, 
being edited or locked by someone else.  You can edit the text in any of these layouts and 
then save the document to save your changes back to GN4.  Within the extDoc you will need 
to update the content if the document is open at the time it was edited within InCopy.

Galley Mode Story Mode Layout Mode
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CREATING A NEW ARTICLE

To create a new article from within InCopy, click on the New Article button in the palette.

At the following screen select the location of the article (folder) and the name of the article 
and click Next.

The New Article screen will open up allowing you to add the text to the various components.  
When you are ready, click Next followed by Finish.  Your new article will now open within 
InCopy.
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INCOPY PLUG-IN MENU OPTIONS

Auto Checkout

Auto Checkout is on by default. It will check out component parts of an item to be edited if 
it is selected with the text tool. When Auto Checkout is on it will unlock the items when the 
document is closed. To toggle this on/off use the menu Plug-Ins>GN4>Auto Checkout. If auto 
checkout is on and you are editing an item and select to check in the item it will re-check 
out the item. With Auto Checkout off, the body component will still be automatically checked 
out for editing but other component parts will have to be manually checked out if editing is 
required.

Jump Reflow

To reflow an existing jump after text content editing, select Plug- Ins>GN4>Jump>Reflow. 
Please note that all the jump parts will need their links updated in each of the document 
pages to enable the ripple effect of edited text to flow backwards/forwards as appropriate.

Linked Images

Toggles the image labels on/off in the InCopy Layout tab, providing the InCopy Screen Mode 
is set to Normal (View>Screen Mode>Normal).

Linked Labels

Toggles the blue content type (body, head etc.) labels on/off in the InCopy Layout tab, 
providing the InCopy Screen Mode is set to Normal (View>Screen Mode>Normal).

Copy Flow Send to Other Folder Options

The Plug-Ins>GN4>Send series of options – Start, Back and On – relate to available copy flow 
options. Articles can be moved from one folder to another utilising GN4 configured workflows 
and the menu items in the same way that they can be moved using the Status Bar Command 
Icons. Plug-Ins>GN4>Send>Start will commence a copy flow on the selected content item. 
Plug-Ins>GN4>Send>Back will send the selected content item back to the previous stage 
setup in the copy flow and Plug-Ins>GN4>Send>On will send the selected content item onto 
the next phase of the configured copy flow.

The Copy Flow features can be used in both InDesign and InCopy to enable a workflow, for 
instance, whereby page content is designed within an InDesign document but sub- edited 
within InCopy. For more information see Sending Articles onto Other Folders.
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THE FITTING AND RULES PALETTES
INTRODUCTION

The Fitting and Rules Palettes are automatically installed when you install the main plug 
in.  They can be accessed from within InDesign under the Window>Miles 33 Fitting and 
Window>Miles33 Rule Palette menu items.  An explanation of the functionality of these two 
items and how to use them will now follow.

THE FITTING PALETTE

The Fitting Palette contains two buttons - Fit Text to box and Undo fit text to box.  

The purpose of this tool is to either stretch or squeeze text to fit into a text frame nicely.  The 
percentage value of the adjustments is configurable and if these values need to be changed 
please contact support for help with this.

To use the fitting palette, with text placed in a text frame, you can click on the Fit text to box 
icon and the text will either space out to fill the text box, or be reduced to fit if it is over-set.  

Fit 
Text

Undo
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The percentage rate of the adjustment is shown within the palette window.  

If the text can not be fitted exactly due to the values set within the configuration, you will see 
the following message.

(An alternative message for when text is unable to be shrunk is also shown).  To undo the 
fitting rule, simply click the Undo button.

THE RULES PALETTE

The Rules palette provides the ability to draw vertical, horizontal and rule around rules.  The 
following is a list of each button and it’s functionality:

1.	 Gutter Rule - adds continuous gutter rules to a box, page or spread, avoiding all other 
items on the page.

2.	 Horizontal Rule - adds a continuous horizontal rule to a page avoiding other items.
3.	 Rule Off - adds continuous rules to rule off any advertising placed on a page by tracing 

around the selected items.
4.	 Rule Around - adds rules to rule around a single shape or a selection of shapes by 

tracing around the selected items .
5.	 Extend Selection - this button allows you to select one of your rules and then when you 

click the Extend Selection button, all other matching rules on the page will be selected 
for you (e.g. select one gutter rule, click the extend selection button and all other gutter 
rules will be selected).  This then allows you to delete them all or style them all at the 
same time.

1 2 3 4 5
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Also on the palette are some configuration parameters as follows:-

	y W - Weight.  The stroke weight that is used to draw the rules
	y M - The minimum length of the rule, any rule that would be less then this length will not 

be drawn (only figures between 0pt and 100pt are accepted).
	y T - Space between the top of an object and the drawn rule.
	y B - Space between the bottom of an object and the drawn rule.
	y A - Space between an object and the rule that is drawn around that object.
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